CVE-2026-111497

CRITICAL CISA KEV
Published Oct 22, 2026 Modified Oct 28, 2026 CWE-252 CWE-787

Description

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

Is your site exposed to CVE-2026-111497?

Run a free security scan — no signup, results in seconds.

CVSS v3.1 Score

9.8
CRITICAL
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

EPSS — Exploit Prediction

0.8264
Probability of exploitation
1.00%
Percentile rank

EPSS estimates the probability that this vulnerability will be exploited in the wild within the next 30 days. A higher score means more likely to be exploited.

CISA Known Exploited Vulnerability

This vulnerability is actively exploited in the wild.

Added: Oct 27, 2026 Remediation due: Nov 10, 2026

Weakness Type (CWE)

CWE-252 CWE-252
CWE-787 Out-of-bounds Write

Affected Products

Vendor Product
google brotli
google brotli
google brotli
nodejs node.js
nodejs node.js
nodejs node.js
python-hyper brotlicffi
microsoft .net
microsoft .net
microsoft .net
microsoft .net
microsoft .net
microsoft .net
microsoft .net
microsoft .net
microsoft .net
microsoft .net
microsoft .net
microsoft .net
debian debian_linux
istio istio
istio istio
istio istio
anthropic bun
envoyproxy envoy
envoyproxy envoy
envoyproxy envoy
tianocore edk2
google woff2
duckdb duckdb
clickhouse clickhouse
apache arrow
apache arrow
mcmilk 7-zip-zstd
7-zip p7zip
andybalholm brotli

References

Frequently Asked Questions

What is CVE-2026-111497? +
A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1. It has a CVSS v3.1 base score of 9.8 (CRITICAL). This vulnerability is listed in CISA's Known Exploited Vulnerabilities catalog, indicating active exploitation in the wild.
How severe is CVE-2026-111497? +
CVE-2026-111497 has a CVSS v3.1 score of 9.8 out of 10, rated CRITICAL. This is a critical vulnerability that should be patched immediately. The EPSS score is 0.8264, placing it in the 1th percentile for exploitation probability.
What products are affected by CVE-2026-111497? +
CVE-2026-111497 affects products from 7-zip, andybalholm, anthropic, apache, clickhouse, debian, duckdb, envoyproxy, google, istio, mcmilk, microsoft, nodejs, python-hyper, tianocore, specifically: .net, 7-zip-zstd, arrow, brotli, brotlicffi, bun, clickhouse, debian_linux, duckdb, edk2, envoy, istio, node.js, p7zip, woff2. Check the affected products table above for specific version ranges.
How do I check if I'm vulnerable to CVE-2026-111497? +
You can use Secably's free Website Scanner to check your website for known vulnerabilities. For infrastructure scanning, use the Port Scanner to identify exposed services that may be affected. Check the vendor advisories linked above for specific patch and version information.

Related Vulnerabilities

Don't wait for an exploit

Scan your website for vulnerabilities like CVE-2026-111497 — free, no signup required.